You are here: Home » Reply

Reply To: On Restart, Song Count = 0

#12460

Anonymous

@rpedde wrote:

@pmorris wrote:

I’ve repurposed a Dell PowerEdge Server to be my home media server. I’m running Ubuntu Feisty Fawn despite my Linux noobness. My MP3 Collection sits on a WD Netcenter. I mount the Netcenter’s filesysem via NFS rather than Samba (which didn’t work so well) See this link for an explanation why. To startup firefly, I:

sudo mount -t nfs 192.168.1.7:/shares/Main/Music /mnt/mp3
sudo mt-daapd

This worked great, but clearly required manual intervention when restarting the server. I wanted it to be automatic, so I added the following link to my /etc/fstab:

192.168.0.200:/shares/Main/Music /mnt/mp3 nfs rw 0 0

Which automates the mounting of the netcenter filesystem on a restart of my server, but when I open Firefly’s Web Admin page, the song count is zero. I can click “Start Full Scan” and it rebuilds the database just fine and the songs play just fine thereafter.

Why doesn’t my song library survive reboots in this configuration? What am I doing wrong?

my guess is that the mountpoint isn’t mapped yet by the time the mt-daapd server starts.

Try changing the start order of the mt-daapd server to 99 or something. There is also a configuration variable called something like ‘skip initial scan’ that you can set to Yes. That will suppress the startup scan, and let the drive get mounted. Probably want to combine that with setting the scan interval to 0 or something large, to allow time for the drive to come online.

— Ron

I set the scan interval to 0 and that took care of everything. Scan Interval of 0 makes an infinite amount of sense. It’s not like I’m adding music every day, so why keep spinning up the drive every hour or so (previous scan interval). And when I do add music, I’m usually sitting there waiting impatiently to listen to it. I can now just hit the “scan” button.

Thanks Ron!