You are here: Home » Reply

Reply To: Slug Has Arrived! …

#12320

rpedde
Participant

@kato wrote:

I tried the ipkg update again and no errors…everything else is still the same

The paths are different on some versions of the unslung firmware. Your path might be /share/flash/data/public/mp3, rather than /share/hdd/data/public.

You can find out by telnetting in and using some unix commands to find the path. Here’s one way to do that.


# mount
/dev/sdb1 on /initrd type jffs2 (rw)
/dev/sdb1 on / type ext3 (rw,noatime)
/proc on /proc type proc (rw)
usbdevfs on /proc/bus/usb type usbdevfs (rw)
/dev/sdb1 on /share/hdd/data type ext3 (rw,noatime)
/dev/sdb2 on /share/hdd/conf type ext3 (rw,sync,noatime)
/dev/sda1 on /share/flash/data type ext3 (rw)
/dev/sda2 on /share/flash/conf type ext3 (rw,sync)
#

On mine, you can see that there are two drives: sda, and sdb. Those correspond to the two slots on the slug (although on mine, sdb is slot1, while sda is slot2, strangely). They each have two partitions (sda1 and sda2, as well as sdb1 and sdb2). The “1” partition is the data partition, and the “2” partition is the conf partition. The slot-1 drive is mounted at /share/flash/data, while the slot-2 drive is mounted at /share/hdd/data.

I can verify that by using the ls command (like dir):


# ls /share/flash/data/public
mp3
#

There is my mp3 directory that I made in public.


# ls /share/hdd/data/public
#

Nothing there. Although you might get something like


ls: /share/hdd/data/public: No such file or directory

if you don’t have a drive mounted there.

So once you figure out what the “right” path to your music is, then you need to change the configuration file.

I’d do something like “ipkg install nano”, and then (as root) “nano /opt/etc/mt-daapd/mt-daapd.conf” to edit the config file. Change the path to the mp3_dir to point to the right place and try starting it again.

One thing you can do to help yourself would be to copy the config file before you start messing with it. You can do that with something like:


# cp /opt/etc/mt-daapd/mt-daapd.conf /opt/etc/mt-daapd/mt-daapd.conf.original

Then if you mess up, you can go back to the original config by copying the old one back:


# cp /opt/etc/mt-daapd/mt-daapd.conf.original /opt/etc/mt-daapd/mt-daapd.conf

When you are in nano editing, you can always hit “ctrl-x” and exit without saving if you mess something up too badly.

Also, I think the windows telnet doesn’t do good terminal emulation, so before you try and edit stuff with nano, you might want to download “putty”, a better telnet client and use that to telnet into the slug.

Yell if this doesn’t get you anywhere.

— Ron