You are here: Home » Reply

Reply To: Share through WAN port?

#11145

rpedde
Participant

@dantidote wrote:

When I enable multicast on the router, the server’s mdns is automagically pushed through somehow. Whatever.

Thanks so much man, you’re really pumping out some quality software, AND you’re super helpful on the forums. Much respect.

I’m assuming this is a campus resnet or something? Kind of nice that the it staff enabled multicast. They don’t usually do that. :), but it’s kind of biting you.

I don’t really see a way around it that’s very good. Even if you turn off the built-in mdns, when you are behind the firewall you need to use the internal address, which will be propagated out to everyone else. And even if you were to get the java dingus to run as a service, you wouldn’t be able to connect to it using that proxied advertisement from inside the firewall.

Maybe the easiest thing is to change the server name to something like “whatever server – internal”, and then set up your bonjour proxy to use “whatever server – external” or something so you can tell them apart.

I could probably add a knob to control TTL, so you could set the TTL on the built-in so it wouldn’t advertise past your router, but that wouldn’t be until next nightlies.

— Ron