You are here: Home » Reply

Reply To: Cannot start Firefly in FC6

#10490

rpedde
Participant

@zak_neutron wrote:

Cheers Ron

Just to check (still a n00b with compiling! 😳 ) my current location for tar is ~/downloads/mt-daapd-0.2.4/ do I still run the “./configure –with-id3tag= /usr/local/lib” WITH your prefix command “with –prefix=/usr”

Ah, sorry, was giving you instructions for nightlies. You want:

./configure –with-id3tag=/usr/local –prefix=/etc

But in 0.2.4, it won’t automatically set up proper paths. But the default config file probably has them in the right place anyway.

Then run the make, then make install?

Yup

Then copy ~/downloads/mt-daapd-0.2.4/contrib/mt-daapd.conf to /etc and edit accordingly?

No, no need. It doesn’t get updated to reflect the prefix settings in 0.2.4, it only does that in nightlies. So just verify that the config you have right now is correct — web_root is /usr/share/mt-daapd/admin-root, and that the db path is /var/cache/mt-daapd. Make sure that’s writable by “nobody”. Might have to make that directory by hand:

# mkdir /var/cache/mt-daapd
# chown nobody /var/cache/mt-daapd

That should probably do it.

Sorry -still learning

Thanks for your help Ron

np. yell if you get stuck.

— Ron