You are here: Home » Reply

Reply To: Install latest nightly on Linkstation Running Debian

#10453

mas
Participant

I am also running debian-etch and this is the configure line I have used for the last compiles:

./configure –prefix=/usr –enable-sqlite3 –enable-nslu2 –enable-avahi –enable-oggvorbis –enable-flac –enable-musepack –enable-upnp –disable-debug

though I do not really know if the enable-nslu2 is neccessary and whether the upnp is much use as I basically only use rsp as protocol. But it works reliably.

I have “aptitude install’ed” basically all packages incl. the devs and the libs which contain sqlite, avahi, ogg, flac, id3tag, vorbis or musepack in its name.

Also I manually patched the vorbis-tools with the tremor integer version, which was the most nasty work as I had to take Rons patch and reverse a little/big endian swap in the src. This vorbis-tool thing is however only needed for on-the-fly transcoding of ogg files. Without the patch the floating-point-emulation would be working and the thing would be too slow and cause massive timeouts. If one doesnt transcode then the last step is not needed.

I think integrating a quick’n dirty oggdec version with an option like –enable-nslu-oggdectremor would be a huge help for less experienced people.

P.S.: superawx, try removing –enable-browse –enable-query. I dont use these and they dont appear to be needed when using avahi. Then remove and reinstall avahi again, reboot and see if avahi gets automatically loaded and then run mt-daapd. Should work. Your problem is definitly somewhere in the announcing. Try running mt-daapd with debug level 9 and see if it correctly announces in the log files.