You are here: Home » Reply

Reply To: Compiling on solaris

#10351

rpedde
Participant

@mjgp2 wrote:

gcc wasn’t on my path…. fixed that but now have another error. Here’s the relevant output… all help appreciated! Thanks 🙂



# ./configure LDFLAGS="-L/opt/local/lib -L/opt/csw/lib" CPPFLAGS="-I/opt/local/include -I/opt/csw/include" --prefix=/opt/local --enable-sqlite3 --disable-mdns --enable-howl --with-howl-includes=/opt/local/include/howl --with-id3tag=/opt/csw

For some reason, the -DHAVE_SQL isn’t getting set. What version is this you are trying to compile? The configure.in sure looks right.

:/

You can manually add -DHAVE_SQL to your CPPFLAGS, that should do it, but there is still an underlying bug.

Also, you don’t want –disable-mdns. That disables all mdns support. Including howl.

— Ron